Customer List page deployment causes personalization to stop working v14 on prem

  • Customer List page deployment causes personalization to stop working v14 on prem

    Posted by Hawlii Allinson on December 7, 2023 at 5:14 pm

    Hi. First time poster here. And I’m stuck!
    I’m using version 14 on prem and made a simple change to the Customer List page to add the existing E-mail field to the columns on that page. This was done in the NAV Development Environment and just added to the datasource list and set the visibility to false, so users could add it only if they wanted to.

    When I tested this in on DEV, everything worked fine. I personalized the page and was able to add in the column. When I deployed the .fob to PROD, now no one is now able to make any personalizations to that Customer List page–no adding the new field or any other field, no removing or moving existing fields. It look like it tries to make a change, by giving the spinning icon for a moment and then nothing happens. I’ve tried clearing the personalizations, which reset everything, but I’m still not able to get the personalizations to stick.

    We have made many, many (too many?) modifications to BC code/pages in the past without issue. This was the first time that we’d touched that page though, so it didn’t find any conflicts when I imported the .fob and just replaced the file. All normal.

    There are also two extensions on this page, but nothing we touched and it’s the same versions/everything on DEV. The only difference on PROD is the permissions, but even as SUPER, I can’t make the personalization work.

    Any thoughts? Has anyone run into anything similar? Thanks in advance.

    Hawlii Allinson replied 2 months, 1 week ago 4 Members · 5 Replies
  • 5 Replies
  • Meenakshi Singh

    Member
    December 11, 2023 at 1:36 pm

    Welcome to the BC/NAV community, Hawlii!

    Community members, has anyone else experienced the same issue and assist in resolving this?

    @kimd @SteveChinsky @shannonmullins @Kristen_Hosman tagging you in case you have seen this with user personalizations.

  • Kim Dallefeld, MVP

    Member
    December 11, 2023 at 1:55 pm

    I have not seen this issue but also have not used version 14 for several years. I would encourage you to move off of version 14 to get the tremendous benefits of the later BC versions.

  • Lewis Rosenberg

    Member
    December 11, 2023 at 7:46 pm

    Welcome Hawlii,

    I am running BC14 on premise, but have not ever experienced the issue that you have.

    My first thought are to try recompiling the object and/or reimporting it. Stopping and starting the BC service also could not hurt.

    • Meenakshi Singh

      Member
      December 12, 2023 at 9:22 pm

      Thanks for responding, Lewis. I didn’t realize you were still using the on-prem version.

    • Hawlii Allinson

      Member
      December 13, 2023 at 8:56 am

      Yes, thank you for the reply, Lewis. I’m waiting an answer as to how a redeployment would work in our versioning and auditing structure before I can try your suggestion. I did bounce the service, but it didn’t change anything. Again, I appreciate the response. It’s a weird one, I know.

Log in to reply.

Welcome to our new site!

Here you will find a wealth of information created for people  that are on a mission to redefine business models with cloud techinologies, AI, automation, low code / no code applications, data, security & more to compete in the Acceleration Economy!