Reply To: Cloud Migration from GP to Business Central

  • Jeff Woodard

    October 7, 2023 at 10:53 am

    I seem to be running into the same issue with the V23 release in a newly spun up trial. It seems much of the documentation hasn’t caught up to the release yet. Installing the Integration runtime was straightforward, as was configuring and running the migration. I’ve got 8 companies, and tried with just 1 company, as well as all 8, but can’t seem to get from running the migration to getting the data in. My most recent attempt, I cleared the cloud data, and started the assisted migration from scratch. I selected all 8 companies, configured the GP migration, and ran it. It ran for approximately 8 hours, and I had 1 table error in one of the companies with a bad XML character.

    After the migration, I see the companies created in BC, but with none of my migrated data other than the company name, and if I look at the ‘not initialized companies’, they are not initialized. At this point, I select each company, and select ‘schedule company initialization’, and after a few seconds and refreshing, they show ‘Initialized’. I’m not sure if this step is necessary, but it seems I’m not able to proceed unless I initialize each company being migrated.

    If I follow the documentation correctly, all my GP data should be in the BC environment in staging tables, and the next step is to ‘Run Data Upgrade now’ option. When I try that, I get the error popup that says:
    “Cannot start upgrade because following companies are not ready to be migrated: <CMPANY1>, <CMPANY2>…. etc.” If I copy the details, it shows:

    Cannot start upgrade because following companies are not ready to be migrated: <redacted>

    Internal session ID:


    Application Insights session ID:


    Client activity id:


    Time stamp on error:


    User telemetry id:


    AL call stack:

    “Hybrid Cloud Management”(CodeUnit 4001).VerifyCanStartUpgrade line 6 – Intelligent Cloud Base by Microsoft

    “Hybrid GP Management”(CodeUnit 4016).InvokeDataUpgrade line 12 – Dynamics GP Intelligent Cloud by Microsoft

    “Hybrid Cloud Management”(CodeUnit 4001).OnInvokeDataUpgrade(Event) line 2 – Intelligent Cloud Base by Microsoft

    “Hybrid Cloud Management”(CodeUnit 4001).RunDataUpgrade line 15 – Intelligent Cloud Base by Microsoft

    “Intelligent Cloud Management”(Page 4003).”RunDataUpgrade – OnAction”(Trigger) line 4 – Intelligent Cloud Base by Microsoft

    Did I miss a step somewhere, or did I run into a bug? I’m not sure where to look for more information on the error being encountered. I also tried with a subset of companies that didn’t have the xml table error and got the same result.

Welcome to our new site!

Here you will find a wealth of information created for people  that are on a mission to redefine business models with cloud techinologies, AI, automation, low code / no code applications, data, security & more to compete in the Acceleration Economy!